Backup Partition To Image File

The function of "Backup Partition To Image File" can backup all available data of a partition include all files in it to a single file or a group of files called "Image File". The partition will be cloned to the image file. So this operation is also called "Clone Partition To Image File".  When the partition is damaged for some reason, it can be restored from the image file(s). And also, in some cases, you can restore the image file to an other partition.

1. Backup Partition.

To start a partition backup process, click the "backup" button on the toolbar, or select the menu "Tools" - "Clone Partition to Image File",  PartitionGuru will popup the following "Backup Partition" dialog box:

Dialog of Backup Partition to Image File

Click " Source partition" button to select a partition you want to backup now, PartitionGuru will popup the following "Partition Select" dialog:

Dialog of Select Partition

Click "Select Image File" button to open the "Open File" dialog and select the target image file.

To save disk space, you can select to compress the image file. There are 4 compress options can be selected, "No compress", "Fast compress", "Normal compress" and "High quality compress". Compress image file may take more time according to which compress mode you select. The higher compress quality, the slower of the partition backup speed will be, and of course the image file will smaller. If no special requirement, "Fast Compress" is suggested.

Before starting the clone partition process, you can enter a remark no more than 800 bytes.

Click the "Start" button to start the partition backup process. The following warning message box will popup:

Dialog of Warning Message

Close all related programs and then click "OK" button. PartitionGuru will try to lock the source partition. If it failed on locking the partition, the following warning message box will be displayed:

Dialog of Warning Message

The process of clone partition to image file may successfully completed while the source partition is not locked. But the data of the files which are changing by other programs during the partition backup process can only be backup to a certain time point. Click "Yes" to start the backup partition process. The following picture shows the backup progress:

Dialog of Backup Partition Progress

2. Restore Partition

When the partition was destroyed, or in other case there is something wrong with the partition, the full partition can be restored from the image file that previously backuped. The restored partition will be same as it was before back up. Click "Tools" - "Restore Partition From Image File" menu item, PartitionGuru will show the following dialogbox:

Dialog of Restore Partition From Image File

Click the "Select Image File" button to select the partition image file. And then click "Target Partition" button to choose the partition which you want to restore. When an Image file is selected, the related information of the partition image file will be displayed. If the image file and the target partition were correctly selected, click the "start" button to prepare for restoring the partition. PartitionGuru will show the following warning message box:

Dialog of Warning Message

Click "OK" if anything is ok. PartitionGuru will start the restoration process.

Dialog of Restore Partition Progress

When the partition is restored completely, the partition and all its files will be restored to the time point which the partition was backuped.

Copyright © 2010 - 2011 Eassos Technology Co., Ltd.